RFC 4035 · March 2005 · R. Arends, R. Austein, M. Larson, D. Massey, S. Rose
Protocol Modifications for the DNS Security Extensions
PROPOSED STANDARDIETF stream
2 verified errata1 held for document update
Index fetched 2026-10-19 from rfc-editor.org
A visual explanation of this RFC hasn't been generated yet. Showing its lineage and text. What's coming
Lineage
100%
Updated by (7)
- RFC 9824 — Compact Denial of Existence in DNSSEC
- RFC 9520 — Negative Caching of DNS Resolution Failures
- RFC 9077 — NSEC and NSEC3: TTLs and Aggressive Use
- RFC 8198 — Aggressive Use of DNSSEC-Validated Cache
- RFC 6840 — Clarifications and Implementation Notes for DNS Security (DNSSEC)
- RFC 6014 — Cryptographic Algorithm Identifier Allocation for DNSSEC
- RFC 4470 — Minimally Covering NSEC Records and DNSSEC On-line Signing
Obsoletes (9)
- RFC 3845 — DNS Security (DNSSEC) NextSECure (NSEC) RDATA Format
- RFC 3757 — Domain Name System KEY (DNSKEY) Resource Record (RR) Secure Entry Point (SEP) Flag
- RFC 3755 — Legacy Resolver Compatibility for Delegation Signer (DS)
- RFC 3658 — Delegation Signer (DS) Resource Record (RR)
- RFC 3655 — Redefinition of DNS Authenticated Data (AD) bit
- RFC 3445 — Limiting the Scope of the KEY Resource Record (RR)
- RFC 3090 — DNS Security Extension Clarification on Zone Status
- RFC 3008 — Domain Name System Security (DNSSEC) Signing Authority
- RFC 2535 — Domain Name System Security Extensions
Updates (8)
- RFC 3597 — Handling of Unknown DNS Resource Record (RR) Types
- RFC 3226 — DNSSEC and IPv6 A6 aware server/resolver message size requirements
- RFC 3225 — Indicating Resolver Support of DNSSEC
- RFC 2308 — Negative Caching of DNS Queries (DNS NCACHE)
- RFC 2181 — Clarifications to the DNS Specification
- RFC 2136 — Dynamic Updates in the Domain Name System (DNS UPDATE)
- RFC 1035 — Domain names - implementation and specification
- RFC 1034 — Domain names - concepts and facilities
Text
Loading the RFC text…