RFC 5246 · August 2008 · T. Dierks, E. Rescorla
The Transport Layer Security (TLS) Protocol Version 1.2
PROPOSED STANDARDIETF stream
Obsoleted by RFC 8446, RFC 9846. Read the newer document for current behaviour.
10 verified errata5 held for document update
Index fetched 2026-10-19 from rfc-editor.org
A visual explanation of this RFC hasn't been generated yet. Showing its lineage and text. What's coming
Lineage
100%
Obsoleted by (2)
Updated by (13)
- RFC 10015 — Deprecating Obsolete Key Exchange Methods in TLS 1.2 and DTLS 1.2
- RFC 9155 — Deprecating MD5 and SHA-1 Signature Hashes in TLS 1.2 and DTLS 1.2
- RFC 8447 — IANA Registry Updates for TLS and DTLS
- RFC 7919 — Negotiated Finite Field Diffie-Hellman Ephemeral Parameters for Transport Layer Security (TLS)
- RFC 7905 — ChaCha20-Poly1305 Cipher Suites for Transport Layer Security (TLS)
- RFC 7685 — A Transport Layer Security (TLS) ClientHello Padding Extension
- RFC 7627 — Transport Layer Security (TLS) Session Hash and Extended Master Secret Extension
- RFC 7568 — Deprecating Secure Sockets Layer Version 3.0
- RFC 7507 — TLS Fallback Signaling Cipher Suite Value (SCSV) for Preventing Protocol Downgrade Attacks
- RFC 7465 — Prohibiting RC4 Cipher Suites
- RFC 6176 — Prohibiting Secure Sockets Layer (SSL) Version 2.0
- RFC 5878 — Transport Layer Security (TLS) Authorization Extensions
- RFC 5746 — Transport Layer Security (TLS) Renegotiation Indication Extension
Obsoletes (3)
Text
Loading the RFC text…