RFC 10015 · July 2026 · N. Aviram
Deprecating Obsolete Key Exchange Methods in TLS 1.2 and DTLS 1.2
PROPOSED STANDARDIETF stream
Index fetched 2026-10-19 from rfc-editor.org
A visual explanation of this RFC hasn't been generated yet. Showing its lineage and text. What's coming
Lineage
100%
Updates (17)
- RFC 9325 — Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)
- RFC 8422 — Elliptic Curve Cryptography (ECC) Cipher Suites for Transport Layer Security (TLS) Versions 1.2 and Earlier
- RFC 7905 — ChaCha20-Poly1305 Cipher Suites for Transport Layer Security (TLS)
- RFC 6655 — AES-CCM Cipher Suites for Transport Layer Security (TLS)
- RFC 6367 — Addition of the Camellia Cipher Suites to Transport Layer Security (TLS)
- RFC 6347 — Datagram Transport Layer Security Version 1.2
- RFC 6209 — Addition of the ARIA Cipher Suites to Transport Layer Security (TLS)
- RFC 5932 — Camellia Cipher Suites for TLS
- RFC 5487 — Pre-Shared Key Cipher Suites for TLS with SHA-256/384 and AES Galois Counter Mode
- RFC 5469 — DES and IDEA Cipher Suites for Transport Layer Security (TLS)
- RFC 5289 — TLS Elliptic Curve Cipher Suites with SHA-256/384 and AES Galois Counter Mode (GCM)
- RFC 5288 — AES Galois Counter Mode (GCM) Cipher Suites for TLS
- RFC 5246 — The Transport Layer Security (TLS) Protocol Version 1.2
- RFC 4785 — Pre-Shared Key (PSK) Ciphersuites with NULL Encryption for Transport Layer Security (TLS)
- RFC 4346 — The Transport Layer Security (TLS) Protocol Version 1.1
- RFC 4279 — Pre-Shared Key Ciphersuites for Transport Layer Security (TLS)
- RFC 4162 — Addition of SEED Cipher Suites to Transport Layer Security (TLS)
Text
Loading the RFC text…