RFC 4346 · April 2006 · T. Dierks, E. Rescorla
The Transport Layer Security (TLS) Protocol Version 1.1
HISTORICIETF stream
Obsoleted by RFC 5246. Read the newer document for current behaviour.
2 verified errata2 held for document update
Index fetched 2026-10-19 from rfc-editor.org
A visual explanation of this RFC hasn't been generated yet. Showing its lineage and text. What's coming
Lineage
100%
Updated by (9)
- RFC 10015 — Deprecating Obsolete Key Exchange Methods in TLS 1.2 and DTLS 1.2
- RFC 7919 — Negotiated Finite Field Diffie-Hellman Ephemeral Parameters for Transport Layer Security (TLS)
- RFC 7507 — TLS Fallback Signaling Cipher Suite Value (SCSV) for Preventing Protocol Downgrade Attacks
- RFC 7465 — Prohibiting RC4 Cipher Suites
- RFC 6176 — Prohibiting Secure Sockets Layer (SSL) Version 2.0
- RFC 5746 — Transport Layer Security (TLS) Renegotiation Indication Extension
- RFC 4681 — TLS User Mapping Extension
- RFC 4680 — TLS Handshake Message for Supplemental Data
- RFC 4366 — Transport Layer Security (TLS) Extensions
Obsoletes (1)
Text
Loading the RFC text…