RFC 2246 · January 1999 · T. Dierks, C. Allen
The TLS Protocol Version 1.0
HISTORICIETF stream
Obsoleted by RFC 4346. Read the newer document for current behaviour.
1 held for document update
Index fetched 2026-10-19 from rfc-editor.org
A visual explanation of this RFC hasn't been generated yet. Showing its lineage and text. What's coming
Lineage
100%
Updated by (6)
- RFC 7919 — Negotiated Finite Field Diffie-Hellman Ephemeral Parameters for Transport Layer Security (TLS)
- RFC 7507 — TLS Fallback Signaling Cipher Suite Value (SCSV) for Preventing Protocol Downgrade Attacks
- RFC 7465 — Prohibiting RC4 Cipher Suites
- RFC 6176 — Prohibiting Secure Sockets Layer (SSL) Version 2.0
- RFC 5746 — Transport Layer Security (TLS) Renegotiation Indication Extension
- RFC 3546 — Transport Layer Security (TLS) Extensions
Text
Loading the RFC text…