RFC 6944 · April 2013 · S. Rose
Applicability Statement: DNS Security (DNSSEC) DNSKEY Algorithm Implementation Status
PROPOSED STANDARDIETF stream
Obsoleted by RFC 8624. Read the newer document for current behaviour.
Index fetched 2026-10-19 from rfc-editor.org
A visual explanation of this RFC hasn't been generated yet. Showing its lineage and text. What's coming
Lineage
100%
Updates (8)
- RFC 5933 — Use of GOST Signature Algorithms in DNSKEY and RRSIG Resource Records for DNSSEC
- RFC 5702 — Use of SHA-2 Algorithms with RSA in DNSKEY and RRSIG Resource Records for DNSSEC
- RFC 5155 — DNS Security (DNSSEC) Hashed Authenticated Denial of Existence
- RFC 4398 — Storing Certificates in the Domain Name System (DNS)
- RFC 4034 — Resource Records for the DNS Security Extensions
- RFC 3110 — RSA/SHA-1 SIGs and RSA KEYs in the Domain Name System (DNS)
- RFC 2539 — Storage of Diffie-Hellman Keys in the Domain Name System (DNS)
- RFC 2536 — DSA KEYs and SIGs in the Domain Name System (DNS)
Text
Loading the RFC text…